summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-07 08:20:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-07 19:43:15 +0100
commit8d038390977376a82ee4902b7188155508133db1 (patch)
treeedd60e9f685a8a4bc139efcacfdc059479c85550 /pyproject.toml
parent13cbcb6de688543befa5d64fcb79df571150d471 (diff)
downloadscons-git-8d038390977376a82ee4902b7188155508133db1.tar.gz
Remove redundant wheel dep from pyproject.toml
Remove the redundant `wheel` dependency, as it is added by the backend automatically. Listing it explicitly in the documentation was a historical mistake and has been fixed since, see: https://github.com/pypa/setuptools/commit/f7d30a9529378cf69054b5176249e5457aaf640a Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1725456de..548ae2d65 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
build-backend = "setuptools.build_meta"
-requires = ["setuptools", "wheel"]
+requires = ["setuptools"]
# for black and mypy, set the lowest Python version supported
[tool.black]