summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
authorWilliam Deegan <bill@baddogconsulting.com>2020-10-09 12:52:57 -0700
committerWilliam Deegan <bill@baddogconsulting.com>2020-10-09 12:52:57 -0700
commitda582df6a7728a16830efd79b811ba19fc8ebb55 (patch)
tree15a18c85905749028bce0b79d18a7e933a2456ba /SConstruct
parentea1da16f6b1601529323943f48bf94f59eb7a785 (diff)
downloadscons-git-da582df6a7728a16830efd79b811ba19fc8ebb55.tar.gz
scons.1 sconsign.1 scons-time.1 now make it into zip, tgz sdist and wheel
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct19
1 files changed, 14 insertions, 5 deletions
diff --git a/SConstruct b/SConstruct
index 2cd2fde63..27235ada7 100644
--- a/SConstruct
+++ b/SConstruct
@@ -12,7 +12,9 @@ copyright_years = strftime('2001 - %Y')
# This gets inserted into the man pages to reflect the month of release.
month_year = strftime('%B %Y')
#
-# __COPYRIGHT__
+# MIT License
+#
+# Copyright The SCons Foundation
#
# Permission is hereby granted, free of charge, to any person obtaining
# a copy of this software and associated documentation files (the
@@ -36,7 +38,7 @@ month_year = strftime('%B %Y')
project = 'scons'
-default_version = '4.0.1'
+default_version = '4.0.1.9998'
copyright = "Copyright (c) %s The SCons Foundation" % copyright_years
#
@@ -193,14 +195,21 @@ Export('command_line', 'env', 'whereis', 'revaction')
SConscript('doc/SConscript')
+# Copy manpage's into base dir for inclusign in pypi packages
+man_pages = env.Install("#/", Glob("#/build/doc/man/*.1"))
+
# Build packages for pypi
-env.Command('$DISTDIR/SCons-${VERSION}-py3-none-any.whl', ['setup.cfg', 'setup.py', 'SCons/__init__.py'],
+wheel = env.Command('$DISTDIR/SCons-${VERSION}-py3-none-any.whl', ['setup.cfg', 'setup.py', 'SCons/__init__.py']+man_pages,
'$PYTHON setup.py bdist_wheel')
-env.Command('$DISTDIR/SCons-${VERSION}.zip', ['setup.cfg', 'setup.py', 'SCons/__init__.py'],
+zip_file = env.Command('$DISTDIR/SCons-${VERSION}.zip', ['setup.cfg', 'setup.py', 'SCons/__init__.py']+man_pages,
'$PYTHON setup.py sdist --format=zip')
-env.Command('$DISTDIR/SCons-${VERSION}.tar.gz', ['setup.cfg', 'setup.py', 'SCons/__init__.py'],
+tgz_file = env.Command('$DISTDIR/SCons-${VERSION}.tar.gz', ['setup.cfg', 'setup.py', 'SCons/__init__.py']+man_pages,
'$PYTHON setup.py sdist --format=gztar')
+# Now set depends so the above run in a particular order
+env.Depends(tgz_file, [zip_file, wheel])
+env.AddPostAction(tgz_file, Delete(man_pages))
+
# TODO add auto copyright date to README.rst, LICENSE
# TODO build API DOCS