summaryrefslogtreecommitdiff
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in23
1 files changed, 20 insertions, 3 deletions
diff --git a/source/configure.in b/source/configure.in
index 170b3c0d1c3..e85f604b584 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -298,9 +298,26 @@ if test "$ac_cv_prog_gnu_ld" = "yes"; then
ac_cv_gnu_ld_date=`echo $ac_cv_gnu_ld_version | sed -n 's,^.*\([2-9][0-9][0-9][0-9]\)[-]*\([01][0-9]\)[-]*\([0-3][0-9]\).*$,\1\2\3,p'`
changequote([,])dnl
AC_MSG_RESULT(${ac_cv_gnu_ld_date})
- if test "$ac_cv_gnu_ld_date" -lt 20030217; then
- ac_cv_gnu_ld_no_default_allow_shlib_undefined=yes
- fi
+ if test -n "$ac_cv_gnu_ld_date"; then
+ if test "$ac_cv_gnu_ld_date" -lt 20030217; then
+ ac_cv_gnu_ld_no_default_allow_shlib_undefined=yes
+ fi
+ else
+ AC_MSG_CHECKING(GNU ld release version)
+ changequote(,)dnl
+ ac_cv_gnu_ld_vernr=`echo $ac_cv_gnu_ld_version | sed -n 's,^.*\([1-9][0-9]*\.[0-9][0-9]*\).*$,\1,p'`
+ ac_cv_gnu_ld_vernr_major=`echo $ac_cv_gnu_ld_vernr | cut -d '.' -f 1`
+ ac_cv_gnu_ld_vernr_minor=`echo $ac_cv_gnu_ld_vernr | cut -d '.' -f 2`
+ changequote([,])dnl
+ AC_MSG_RESULT(${ac_cv_gnu_ld_vernr})
+ AC_MSG_CHECKING(GNU ld release version major)
+ AC_MSG_RESULT(${ac_cv_gnu_ld_vernr_major})
+ AC_MSG_CHECKING(GNU ld release version minor)
+ AC_MSG_RESULT(${ac_cv_gnu_ld_vernr_minor})
+ if test "$ac_cv_gnu_ld_vernr_major" -lt 2 || test "$ac_cv_gnu_ld_vernr_minor" -lt 14; then
+ ac_cv_gnu_ld_no_default_allow_shlib_undefined=yes
+ fi
+ fi
fi
dnl needed before AC_TRY_COMPILE