summaryrefslogtreecommitdiff
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in36
1 files changed, 1 insertions, 35 deletions
diff --git a/source/configure.in b/source/configure.in
index 25d1a4380f2..6809d2fe8fc 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1125,45 +1125,11 @@ AC_ARG_WITH(nisplus-home,
AC_MSG_CHECKING(whether to use SSL)
AC_ARG_WITH(ssl,
[ --with-ssl Include SSL support
- --without-ssl Don't include SSL support (default)
- --with-sslinc=DIR Where the SSL includes are (defaults to /usr/local/ssl)],
+ --without-ssl Don't include SSL support (default)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_SSL)
- withval="/usr/local/ssl" # default
-
- if test "${with_sslinc+set}" = set; then
-
- withval="$with_sslinc"
- case "$withval" in
- yes|no)
- echo "configure: warning: --with-sslinc called without argument - will use default" 1>&w
- CFLAGS="-I/usr/local/ssl/include $CFLAGS"
- LIBS="-lssl -lcrypto $LIBS"
- LDFLAGS="=L/usr/local/ssl/lib $LDFLAGS"
- ;;
- * )
- CFLAGS="-I${withval}/include $CFLAGS"
- LIBS="-lssl -l crypto $LIBS"
- LDFLAGS="-L${withval}/lib $LDFLAGS"
- ;;
- esac
-
- else
-
- CFLAGS="-I/usr/local/ssl/include $CFLAGS"
- LIBS="-lssl -lcrypto $LIBS"
- LDFLAGS="-L/usr/local/ssl/lib $LDFLAGS"
-
- fi
-
- if test ! -d ${withval}; then
- { echo "configure: error: called with --with-ssl, but ssl base directory ${withval} does not exist or is not a directory. Aborting config" 1>&2; exit 1 }
- fi
-
- CFLAGS="-DHAVE_CRYPT_DECL $CFLAGS" # Damn, SSLeay defines its own
-
;;
*)
AC_MSG_RESULT(no)