summaryrefslogtreecommitdiff
path: root/third_party/heimdal/configure.ac
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2022-10-31 14:33:09 +1300
committerAndrew Bartlett <abartlet@samba.org>2022-11-02 04:23:34 +0000
commitef28247f3bbbd7cf9daed7a4dba28855496ce38e (patch)
treef97d5b9b41ebbfb7e52269486b3c41d9a0fd9575 /third_party/heimdal/configure.ac
parentab4c7bda8daccdb99adaf6ec7fddf8b5f84be09a (diff)
downloadsamba-ef28247f3bbbd7cf9daed7a4dba28855496ce38e.tar.gz
third_party/heimdal: import lorikeet-heimdal-202210310104 (commit 0fc20ff4144973047e6aaaeb2fc8708bd75be222)
This commit won't compile on it's own, as we need to fix the build system to cope in the next commit. The purpose of this commit is to update to a new lorikeet-heimdal tree that includes the previous two patches and is rebased on a current Heimdal master snapshot. Signed-off-by: Andrew Bartlett <abartlet@samba.org> Reviewed-by: Joseph Sutton <josephsutton@catalyst.net.nz>
Diffstat (limited to 'third_party/heimdal/configure.ac')
-rw-r--r--third_party/heimdal/configure.ac20
1 files changed, 12 insertions, 8 deletions
diff --git a/third_party/heimdal/configure.ac b/third_party/heimdal/configure.ac
index 8c0b746ba5c..b946dfff4c1 100644
--- a/third_party/heimdal/configure.ac
+++ b/third_party/heimdal/configure.ac
@@ -505,16 +505,20 @@ rk_WIN32_EXPORT(BUILD_ROKEN_LIB, ROKEN_LIB)
rk_WIN32_EXPORT(BUILD_GSSAPI_LIB, GSSAPI_LIB)
rk_WIN32_EXPORT(BUILD_KDC_LIB, KDC_LIB)
-dnl Deal with switch FALLTHROUGH
+dnl Deal with switch fallthrough warnings
AH_TOP([
-#if defined(__GNUC__)
-#if __GNUC__ >= 7
-# define fallthrough __attribute__((fallthrough))
+#if defined(DISPATCH_FALLTHROUGH)
+# define HEIM_FALLTHROUGH DISPATCH_FALLTHROUGH
#else
-# define fallthrough do {} while (0) /* fallthrough */
-#endif
-#else
-# define fallthrough do {} while (0) /* fallthrough */
+# if defined(__GNUC__)
+# if __GNUC__ >= 7
+# define HEIM_FALLTHROUGH __attribute__((fallthrough))
+# else
+# define HEIM_FALLTHROUGH do {} while (0) /* fallthrough */
+# endif
+# else
+# define HEIM_FALLTHROUGH do {} while (0) /* fallthrough */
+# endif
#endif
])