summaryrefslogtreecommitdiff
path: root/source/lib/tdb/configure.ac
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2008-09-14 19:21:54 +0200
committerStefan Metzmacher <metze@samba.org>2008-09-14 19:23:00 +0200
commitbdb8ed24488fd87cd30dd18744feeef0bd4b2c18 (patch)
treedb6e7604f63c81f193d74d65e328d8b26640dd0d /source/lib/tdb/configure.ac
parent0143c320ccf21c00e1a09b8363cd42724b76faf9 (diff)
downloadsamba-v3-devel.tar.gz
lib/tdb: sync build system changes and python code from samba4v3-devel
metze
Diffstat (limited to 'source/lib/tdb/configure.ac')
-rw-r--r--source/lib/tdb/configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/source/lib/tdb/configure.ac b/source/lib/tdb/configure.ac
index 14761bcc1a5..eaf70d30b44 100644
--- a/source/lib/tdb/configure.ac
+++ b/source/lib/tdb/configure.ac
@@ -2,13 +2,29 @@ AC_PREREQ(2.50)
AC_DEFUN([SMB_MODULE_DEFAULT], [echo -n ""])
AC_DEFUN([SMB_LIBRARY_ENABLE], [echo -n ""])
AC_DEFUN([SMB_ENABLE], [echo -n ""])
-AC_INIT(tdb, 1.1.1)
+AC_INIT(tdb, 1.1.2)
AC_CONFIG_SRCDIR([common/tdb.c])
AC_CONFIG_HEADER(include/config.h)
AC_LIBREPLACE_ALL_CHECKS
AC_LD_SONAMEFLAG
AC_LD_PICFLAG
AC_LD_SHLIBEXT
+AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
+AC_LIBREPLACE_RUNTIME_LIB_PATH_VAR
m4_include(libtdb.m4)
+AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
+AC_PATH_PROGS([PYTHON], [python2.6 python2.5 python2.4 python])
+
+PYTHON_BUILD_TARGET="build-python"
+PYTHON_INSTALL_TARGET="install-python"
+PYTHON_CHECK_TARGET="check-python"
+AC_SUBST(PYTHON_BUILD_TARGET)
+AC_SUBST(PYTHON_INSTALL_TARGET)
+AC_SUBST(PYTHON_CHECK_TARGET)
+if test -z "$PYTHON_CONFIG"; then
+ PYTHON_BUILD_TARGET=""
+ PYTHON_INSTALL_TARGET=""
+ PYTHON_CHECK_TARGET=""
+fi
AC_OUTPUT(Makefile tdb.pc)