summaryrefslogtreecommitdiff
path: root/source/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vlendec@samba.org>2004-05-02 12:13:16 +0000
committerVolker Lendecke <vlendec@samba.org>2004-05-02 12:13:16 +0000
commit2399821d94464cd13f31b54ed7f5c554fc930bd1 (patch)
tree3729fadc5865a15003d359f38ad4ff58f46c9538 /source/configure.in
parent8f9ef7d6bb833ae186a5e8549e226ccf7ba5c0a9 (diff)
downloadsamba-2399821d94464cd13f31b54ed7f5c554fc930bd1.tar.gz
r449: Two AFS-related things:
Split off the non-crypto related parts of lib/afs.c into lib/afs_settoken.c. This makes wbinfo link without -lcrypto. Commit vfs_afsacl.c, display & set AFS acls via the NT security editor. Volker
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in27
1 files changed, 23 insertions, 4 deletions
diff --git a/source/configure.in b/source/configure.in
index 8f61241a629..f4383ea337b 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2377,13 +2377,31 @@ if test x"$samba_cv_WITH_AFS" != x"no" ||
fi
fi
-if test x"$samba_cv_WITH_FAKE_KASERVER" != x"no"; then
- AC_CHECK_LIB( crypto, DES_pcbc_encrypt, LIBS="$LIBS -lcrypto" )
-fi
-
if test x"$samba_cv_WITH_FAKE_KASERVER" != x"no" && test x"$have_afs_headers" == x"yes"; then
AC_DEFINE(WITH_FAKE_KASERVER,1,[Whether to include AFS fake-kaserver support])
fi
+
+#################################################
+# check whether to compile AFS/NT ACL mapping module
+samba_cv_WITH_VFS_AFSACL=no
+AC_MSG_CHECKING(whether to use AFS fake-kaserver)
+AC_ARG_WITH(vfs-afsacl,
+[ --with-vfs-afsacl Include AFS to NT ACL mapping module (default=no) ],
+[ case "$withval" in
+ yes|auto)
+ AC_MSG_RESULT($withval)
+ samba_cv_WITH_VFS_AFSACL=yes
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+if test x"$samba_cv_WITH_VFS_AFSACL" == x"yes"; then
+ default_shared_modules="$default_shared_modules vfs_afsacl"
+fi
if test x"$samba_cv_WITH_AFS" != x"no" && test x"$have_afs_headers" = x"yes"; then
AC_DEFINE(WITH_AFS,1,[Whether to include AFS clear-text auth support])
@@ -4337,6 +4355,7 @@ SMB_MODULE(vfs_readonly, \$(VFS_READONLY_OBJ), "bin/readonly.$SHLIBEXT", VFS)
SMB_MODULE(vfs_cap, \$(VFS_CAP_OBJ), "bin/cap.$SHLIBEXT", VFS)
SMB_MODULE(vfs_expand_msdfs, \$(VFS_EXPAND_MSDFS_OBJ), "bin/expand_msdfs.$SHLIBEXT", VFS)
SMB_MODULE(vfs_shadow_copy, \$(VFS_SHADOW_COPY_OBJ), "bin/shadow_copy.$SHLIBEXT", VFS)
+SMB_MODULE(vfs_afsacl, \$(VFS_AFSACL_OBJ), "bin/afsacl.$SHLIBEXT", VFS)
SMB_SUBSYSTEM(VFS,smbd/vfs.o)
AC_DEFINE_UNQUOTED(STRING_STATIC_MODULES, "$string_static_modules", [String list of builtin modules])