summaryrefslogtreecommitdiff
path: root/src/plugins/gst-launch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/gst-launch/Makefile.am')
-rw-r--r--src/plugins/gst-launch/Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/src/plugins/gst-launch/Makefile.am b/src/plugins/gst-launch/Makefile.am
index bdc26193..779e87c8 100644
--- a/src/plugins/gst-launch/Makefile.am
+++ b/src/plugins/gst-launch/Makefile.am
@@ -2,10 +2,6 @@ include $(top_srcdir)/common.am
plugin_LTLIBRARIES = librygel-gst-launch.la
-AM_CFLAGS += -DG_LOG_DOMAIN='"GstLaunch"' \
- -I$(top_srcdir)/src/media-engines/gstreamer \
- $(LIBGSTREAMER_CFLAGS)
-
librygel_gst_launch_la_SOURCES = \
rygel-gst-launch-plugin.vala \
rygel-gst-launch-root-container.vala \
@@ -16,9 +12,16 @@ librygel_gst_launch_la_SOURCES = \
librygel_gst_launch_la_VALAFLAGS = \
--enable-experimental \
- --pkg gstreamer-1.0 \
- $(RYGEL_COMMON_SERVER_PLUGIN_VALAFLAGS)
+ $(RYGEL_PLUGIN_GST_LAUNCH_DEPS_VALAFLAGS) \
+ $(RYGEL_COMMON_LIBRYGEL_SERVER_VALAFLAGS) \
+ $(RYGEL_COMMON_VALAFLAGS)
+librygel_gst_launch_la_CFLAGS = \
+ $(RYGEL_PLUGIN_GST_LAUNCH_DEPS_CFLAGS) \
+ $(RYGEL_COMMON_LIBRYGEL_SERVER_CFLAGS) \
+ -I$(top_srcdir)/src/media-engines/gstreamer \
+ -DG_LOG_DOMAIN='"GstLaunch"'
librygel_gst_launch_la_LIBADD = \
- $(LIBGSTREAMER_LIBS) \
- $(RYGEL_COMMON_SERVER_LIBS)
-librygel_gst_launch_la_LDFLAGS = $(RYGEL_PLUGIN_LINKER_FLAGS)
+ $(RYGEL_PLUGIN_GST_LAUNCH_DEPS_LIBS) \
+ $(RYGEL_COMMON_LIBRYGEL_SERVER_LIBS)
+librygel_gst_launch_la_LDFLAGS = \
+ $(RYGEL_PLUGIN_LINKER_FLAGS)