summaryrefslogtreecommitdiff
path: root/src/ui/Makefile.am
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2012-12-07 15:59:46 +0100
committerJens Georg <jensg@openismus.com>2012-12-12 19:58:26 +0100
commitf6a03475fa096b01a4b01747bba789e2b1d67360 (patch)
treed5fc75947b8e83781fc51a8a2da0c2f56d267c33 /src/ui/Makefile.am
parent0a780ba217ef26ce6e03328a5c5c3c8372f5b149 (diff)
downloadrygel-f6a03475fa096b01a4b01747bba789e2b1d67360.tar.gz
build: Improve the build
* configure.ac: Mention dependencies as executable/library-specific PKG_CHECK_MODULES() calls, instead of having one PKG_CHECK_MODULE() call for each dependency and then listing those depdendencies' CFLAGS and LIBS individually in each Makefile.am. Also define the _VALAFLAGS in the same place, keeping things consistent. * common.am: Clean this up, using more obvious variable names. * various Makefile.am: Use the new structure. Do not use AM_CFLAGS, instead specifying the CFLAGS, LIBS and VALAFLAGS for each executable/library. As well as being cleaner, this would allow us to convert to a non-recursive autotools build sometime in the future. https://bugzilla.gnome.org/show_bug.cgi?id=689960
Diffstat (limited to 'src/ui/Makefile.am')
-rw-r--r--src/ui/Makefile.am28
1 files changed, 16 insertions, 12 deletions
diff --git a/src/ui/Makefile.am b/src/ui/Makefile.am
index 3704aa11..c050311d 100644
--- a/src/ui/Makefile.am
+++ b/src/ui/Makefile.am
@@ -1,10 +1,5 @@
include ../../common.am
-AM_CFLAGS += \
- $(GTK_CFLAGS) \
- -DSMALL_ICON_DIR='"$(icondir)"' \
- -DLOCALEDIR=\""$(datadir)/locale"\" -DG_LOG_DOMAIN='"Rygel"'
-
bin_PROGRAMS = rygel-preferences
rygel_preferences_SOURCES = \
@@ -16,12 +11,21 @@ rygel_preferences_SOURCES = \
rygel-user-config.vala
rygel_preferences_VALAFLAGS = \
- --pkg gio-2.0 \
- --pkg gtk+-3.0 $(RYGEL_COMMON_PLUGIN_VALAFLAGS)
+ $(RYGEL_UI_DEPS_VALAFLAGS) \
+ $(RYGEL_COMMON_LIBRYGEL_CORE_VALAFLAGS) \
+ $(RYGEL_COMMON_VALAFLAGS)
+rygel_preferences_CFLAGS = \
+ $(RYGEL_UI_DEPS_CFLAGS) \
+ $(RYGEL_COMMON_LIBRYGEL_CORE_CFLAGS) \
+ -DSMALL_ICON_DIR='"$(icondir)"' \
+ -DLOCALEDIR=\""$(datadir)/locale"\" \
+ -DG_LOG_DOMAIN='"Rygel"' \
+ -DDESKTOP_DIR='"$(desktopdir)"' \
+ -DSYS_CONFIG_DIR='"$(sysconfigdir)"'
rygel_preferences_LDADD = \
- $(RYGEL_COMMON_LIBS) \
- $(LIBGSSDP_LIBS) \
- $(GTK_LIBS)
-rygel_preferences_LDFLAGS = -export-dynamic
-
+ $(RYGEL_UI_DEPS_LIBS) \
+ $(RYGEL_COMMON_LIBRYGEL_CORE_LIBS)
+rygel_preferences_LDFLAGS = \
+ $(RYGEL_DATA_DIR_DEFINES) \
+ -export-dynamic