summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorZeeshan Ali (Khattak) <zeeshanak@gnome.org>2009-05-25 17:43:34 +0300
committerZeeshan Ali (Khattak) <zeeshanak@gnome.org>2009-05-25 17:43:34 +0300
commitcbf51922568943c51aa22d49187f31241877b039 (patch)
tree8f234e9ddc27abf11659c1ff2aa5ccfc8720c3d9 /data/Makefile.am
parente818921c2cb98e8039e7f3a43620224213d80ed3 (diff)
downloadrygel-cbf51922568943c51aa22d49187f31241877b039.tar.gz
Provide GConf schemas
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 093ab7c9..80f48b59 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,9 +1,19 @@
SUBDIRS = xml
+schemadir = @GCONF_SCHEMA_FILE_DIR@
+schema_DATA = rygel.schemas
+
shareddir = $(datadir)/rygel
if BUILD_UI
dist_shared_DATA = rygel-preferences.ui
endif
+if GCONF_SCHEMAS_INSTALL
+install-data-local: $(schema_DATA)
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$(schema_DATA);
+endif
+
+EXTRA_DIST = $(schema_DATA)
+
MAINTAINERCLEANFILES = Makefile.in