summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2016-05-11 23:37:41 +0200
committerJens Georg <mail@jensge.org>2016-05-19 21:26:01 +0200
commitf2065867c8fa6ec4e1d493b99ba5ac2f2526bf79 (patch)
tree3391f5161862a05764f01b5556d9c1226f54ba60 /configure.ac
parent081a02c119c76196eb4852ee526cb5a894c4077d (diff)
downloadrygel-f2065867c8fa6ec4e1d493b99ba5ac2f2526bf79.tar.gz
data: Add a way for Rygel to be started via user systemd
This will allow better tracking of whether rygel is running, ensuring that even if the manager to enable/disable its startup (gnome-settings-daemon) crashes and needs to restart, its status is still available by querying the user systemd. https://bugzilla.gnome.org/show_bug.cgi?id=766332
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index def6eaa0..88fba8ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,6 +403,15 @@ AS_IF([test "x$enable_coverage" != "xno"],
]
)
+dnl systemd user unit directory
+AC_ARG_WITH([systemduserunitdir],
+ AS_HELP_STRING([--with-systemduserunitdir=DIR], [Directory for systemd user service files]),
+ [],
+ [with_systemduserunitdir=$($PKG_CONFIG --variable=systemduserunitdir systemd)])
+if test x$with_systemduserunitdir != xno; then
+ AC_SUBST([systemduserunitdir], [$with_systemduserunitdir])
+fi
+
dnl Check additional requirements for MediaExport plugins
if test "x$enable_media_export_plugin" = "xyes";
then