summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2012-12-05 10:30:10 +0100
committerMurray Cumming <murrayc@murrayc.com>2012-12-05 10:30:10 +0100
commitdb42c372d6e82d8de61b3967a6229cffd69a2d02 (patch)
tree612cdda3f76b078fc438b6d923cc98df0a97c431 /configure.ac
parent8e56fa5d1351633a170dd25f2a60eacd5288b0b0 (diff)
downloadrygel-db42c372d6e82d8de61b3967a6229cffd69a2d02.tar.gz
Change --with-media-engine=none to =simple
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d8946df2..a03f4f9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,7 @@ LT_PREREQ([2.2.6])
LT_INIT([dlopen disable-static])
dnl Required versions of library packages
+dnl Not all of these are actually used, depending on the configure options.
GLIB_REQUIRED=2.31.13
LIBXML_REQUIRED=2.7
VALA_REQUIRED=0.18.0
@@ -67,9 +68,11 @@ PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED)
dnl Media engine to use
BUILT_ENGINES="librygel-media-engine-simple"
+dnl Disabling the gstreamer media_engine also disables
+dnl anything else that uses gstreamer.
AC_ARG_WITH([media_engine],
AS_HELP_STRING(
- [--with-media-engine=@<:@gstreamer|none@:>@],
+ [--with-media-engine=@<:@gstreamer|simple@:>@],
[Media Engine to use]),
[with_media_engine="$withval"],
[with_media_engine="gstreamer"])