summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2013-11-21 14:19:50 +0200
committerJens Georg <mail@jensge.org>2016-01-17 22:25:17 +0100
commitcb0ea8fef9d653a22f75a655ae3f430888f82a5c (patch)
tree87240dc67f43066609d8d0b06108e2396efcecb5 /configure.ac
parentf164bb98f9b548a129a836f00ab6fb0e70f73b65 (diff)
downloadrygel-cb0ea8fef9d653a22f75a655ae3f430888f82a5c.tar.gz
lms: Add LightMediascanner plugin
LightMediaScanner is a media indexer similar to Tracker. https://github.com/profusion/lightmediascanner
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 89557c35..512c0396 100644
--- a/configure.ac
+++ b/configure.ac
@@ -239,6 +239,18 @@ AS_IF([test "x$enable_ruih_plugin" = "xyes"],
libxml-2.0 >= $LIBXML_REQUIRED])
])
+
+RYGEL_ADD_PLUGIN([lms],[LightMediaScanner],[yes])
+AS_IF([test "x$enable_lms_plugin" = "xyes"],
+ [
+ PKG_CHECK_MODULES([RYGEL_PLUGIN_LMS_DEPS],
+ [$RYGEL_COMMON_MODULES
+ gio-2.0 >= $GIO_REQUIRED
+ sqlite3 >= $LIBSQLITE3_REQUIRED])
+ RYGEL_PLUGIN_LMS_DEPS_VALAFLAGS="$RYGEL_COMMON_MODULES_VALAFLAGS --pkg gio-2.0 --pkg gee-0.8 --pkg rygel-server-2.0 --pkg rygel-core-2.0 --pkg sqlite3"
+ AC_SUBST([RYGEL_PLUGIN_LMS_DEPS_VALAFLAGS])
+ ])
+
AS_IF([test "x$with_media_engine" = "xgstreamer"],
[
RYGEL_ADD_PLUGIN([playbin],[GStreamer playbin],[yes])
@@ -394,6 +406,11 @@ then
RYGEL_CHECK_PACKAGES([gstreamer-tag-1.0 gstreamer-app-1.0])
fi
+dnl Check additional requirements for LMS plugin
+if test "x$enable_lms_plugin" = "xyes";
+then
+ RYGEL_CHECK_PACKAGES([sqlite3])
+fi
RYGEL_ADD_PLUGIN([tracker],[Tracker],[yes])
AS_IF([test "x$enable_tracker_plugin" = "xyes"],
@@ -578,6 +595,7 @@ echo "
version: ${tracker_api_version}
mediathek: ${enable_mediathek_plugin}
media-export ${enable_media_export_plugin}
+ lightmediascanner ${enable_lms_plugin}
external: ${enable_external_plugin}
MPRIS2: ${enable_mpris_plugin}
gst-launch: ${enable_gst_launch_plugin}