summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2017-05-20 12:44:51 +0200
committerJens Georg <mail@jensge.org>2017-05-20 12:46:16 +0200
commit77f767e9872032398cb7f93d77ee70fee89de3ae (patch)
tree7443c10b231f82ef8df4bedf2695b5fc2ee9d4ad /configure.ac
parente04c234f8c356fefc34e0bf6eea796316ad8781f (diff)
downloadrygel-77f767e9872032398cb7f93d77ee70fee89de3ae.tar.gz
build: We need gstreamer-base-1.0 for the engine
For some reason (maybe legacy) we seem to link app which was also pulling in base.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d9228a4..20d6893a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,7 @@ MEDIAART_REQUIRED=0.7.0
dnl Additional requirements for media-export plugin
GSTREAMER_TAG_REQUIRED=1.0
GSTREAMER_APP_REQUIRED=1.0
+GSTREAMER_BASE_REQUIRED=1.0
LIBSQLITE3_REQUIRED=3.5
dnl Additional requirements for playbin plugin
@@ -192,7 +193,7 @@ AS_IF([test "x$with_media_engine" = "xgstreamer"],
PKG_CHECK_MODULES([RYGEL_MEDIA_ENGINE_GSTREAMER_DEPS],
[$RYGEL_COMMON_MODULES
gstreamer-pbutils-1.0 >= $GSTPBU_REQUIRED
- gstreamer-app-1.0 >= $GSTREAMER_APP_REQUIRED
+ gstreamer-base-1.0 >= $GSTREAMER_BASE_REQUIRED
gupnp-dlna-2.0 >= $GUPNP_DLNA_REQUIRED
libsoup-2.4 >= $LIBSOUP_REQUIRED
gio-2.0 >= $GIO_REQUIRED])