summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2018-01-11 20:38:55 +0100
committerJens Georg <mail@jensge.org>2018-01-11 20:38:55 +0100
commit6b75529d406eb5e8d9a8256de17bb9e2f4399ec5 (patch)
tree2250070eef308d1357a7675abd950588ee64c2a7 /configure.ac
parent2fac7194c7d3a2f8a0c0a6fffd62298a60d5d611 (diff)
downloadrygel-6b75529d406eb5e8d9a8256de17bb9e2f4399ec5.tar.gz
build: Fail configure if no tracker-sparql was not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00b94dab..c51d580a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -427,6 +427,9 @@ AS_IF([test "x$enable_tracker_plugin" = "xyes"],
tracker_api_version="VERSION"
])
])
+ AS_IF([test "x:$trackerpkg" = "x:"],
+ [AC_MSG_ERROR([No supported API version of the tracker-sparql library was found])])
+
PKG_CHECK_MODULES([RYGEL_PLUGIN_TRACKER_DEPS],
[$RYGEL_COMMON_MODULES gio-2.0 >= $GIO_REQUIRED ${trackerpkg}])