summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2011-02-25 00:55:30 +0100
committerJens Georg <mail@jensge.org>2011-07-22 00:06:57 +0200
commit592bee9125faf9ba0b5b1449857c6554435c8f29 (patch)
tree647f2796bf86227d856a80f7cd7cf2f517d88e51 /configure.ac
parent2d47302f4528e580af36b765cb3407f55a0e4466 (diff)
downloadrygel-592bee9125faf9ba0b5b1449857c6554435c8f29.tar.gz
media-export: Get rid of callbacks in database
Actually most of the code using the callback approach was more like a loop body. Now we have a database cursor that can be used with vala's foreach syntax, removing some indirection. Note: This also drops SQL debugging which will be re-introduced later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0d371c56..80a620d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,12 +74,6 @@ dnl glib-genmarshal
GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)
-AC_ARG_ENABLE(sql-debugging,
- AS_HELP_STRING([--enable-sql-debugging],[enable SQL statement debugging]),,
- enable_sql_debugging=no)
-AS_IF([test x$enable_sql_debugging = xyes],
- [RYGEL_ADD_VALAFLAGS([-D RYGEL_DEBUG_SQL])])
-
dnl Add plugins
RYGEL_ADD_PLUGIN([test],[Test],[no])
RYGEL_ADD_PLUGIN([tracker],[Tracker],[yes])
@@ -231,7 +225,6 @@ echo "
VALAFLAGS: ${VALAFLAGS}
uninstalled: ${enable_uninstalled}
preferences ui: ${BUILD_UI}
- SQL debugging: ${enable_sql_debugging}
Plugins:
test: ${enable_test_plugin}
tracker: ${enable_tracker_plugin}