summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2018-01-08 21:38:54 +0100
committerJens Georg <mail@jensge.org>2018-03-01 18:44:29 +0100
commit5899cdfe9ff650eb8b71c2486154bc01a7629ffa (patch)
tree40ba0388ae6d475c23922c94a00bd39b95bd5eb9 /configure.ac
parent6c92095ab13a5695ca5add2085309e345552546b (diff)
downloadrygel-5899cdfe9ff650eb8b71c2486154bc01a7629ffa.tar.gz
Allow UI build without gstreamer-video
If EXAMPLE_UI dependencies are not met, only display a warning instead of ending configure with an error. Indeed, currently, we can't build rygel UI without gstreamer-video which is only a dependency of fullscreen-renderer application. fullscreen-renderer won't be build without gstreamer as HAVE_GSTREAMER has to be true to check HAVE_UI in examples/Makefile.am Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> https://bugzilla.gnome.org/show_bug.cgi?id=792358
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c51d580a..b4ee95b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,7 +359,11 @@ if test x$try_ui = xyes ; then
[$RYGEL_COMMON_MODULES gio-2.0 >= $GIO_REQUIRED
gssdp-1.0 >= $GSSDP_REQUIRED
gstreamer-video-1.0 >= $GSTREAMER_REQUIRED
- gtk+-3.0 >= $GTK_REQUIRED])
+ gtk+-3.0 >= $GTK_REQUIRED],,
+ [
+ AC_MSG_WARN([Example UI dependencies not found.])
+ AC_MSG_WARN([Example UI applications will not be built.])
+ ])
],
[
AC_MSG_WARN([UI dependencies not found.])