summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2015-04-24 08:54:04 +0200
committerJens Georg <mail@jensge.org>2015-04-24 19:15:30 +0200
commit1f142319a3cc21a82e434d19ae973b4517154bd3 (patch)
tree4be0cdcf8922f48dab168db10c9bd984e15a981c /configure.ac
parent63d9d50bfe7c2c5ee79982d66d141fe6a3481e3c (diff)
downloadrygel-1f142319a3cc21a82e434d19ae973b4517154bd3.tar.gz
build: Stop leaking symbols in plugins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c085ed5c..a38a8ada 100644
--- a/configure.ac
+++ b/configure.ac
@@ -421,7 +421,9 @@ AS_IF([test "x$enable_apidocs" != "xno"], [
AM_CONDITIONAL(ENABLE_VALADOC, test x$found_valadoc = xyes)
AC_SUBST([RYGEL_PLUGIN_LINKER_FLAGS],
- ["-module -avoid-version"])
+ ["-module -avoid-version -shared -export-dynamic -export-symbols-regex 'module_init'"])
+AC_SUBST([RYGEL_ENGINE_LINKER_FLAGS],
+ ["-module -avoid-version -shared -export-dynamic -export-symbols-regex 'module_get_instance'"])
AC_SUBST([RYGEL_PLUGIN_DIR],
[${libdir}/rygel-2.6/plugins])
AC_SUBST([RYGEL_MEDIA_ENGINE_DIR],