summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorReynaldo H. Verdejo Pinochet <reynaldo@collabora.com>2013-08-30 13:18:25 -0400
committerJens Georg <jensg@openismus.com>2013-09-02 19:09:48 +0200
commit0d2159a7a59fad250e02f039b38d4fa8a7c8e211 (patch)
tree4675d08dd316e7cc396ccdd4d31ad863f49b16de /configure.ac
parent25888576a96482352a686d06e28c96f9cd302f95 (diff)
downloadrygel-0d2159a7a59fad250e02f039b38d4fa8a7c8e211.tar.gz
Buildsystem: Drop harcoded -shared -fPIC flags
This fix gets around a libtool's "cannot build a shared library" error when crosscompiling/linking media-engine-simple with Android's NDK r8e toolchain. These flags are being correctly handled by auto*/libtool (as they probably should). https://bugzilla.gnome.org/show_bug.cgi?id=707146
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3e67688e..e0ca7a37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,7 +378,7 @@ AS_IF([test "x$enable_valadoc" != "xno"], [
AM_CONDITIONAL(ENABLE_VALADOC, test x$found_valadoc = xyes)
AC_SUBST([RYGEL_PLUGIN_LINKER_FLAGS],
- ["-shared -fPIC -module -avoid-version -Wl,-z,defs"])
+ ["-module -avoid-version -Wl,-z,defs"])
AC_SUBST([RYGEL_PLUGIN_DIR],
[${libdir}/rygel-2.0/plugins])
AC_SUBST([RYGEL_MEDIA_ENGINE_DIR],