summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2013-03-21 13:56:33 +0200
committerPanu Matilainen <pmatilai@redhat.com>2013-03-21 13:56:33 +0200
commitb5e3e1efee28ce0a4bb5e9eae6740d4422f75f1c (patch)
treef7a99d42641f8816f30ee54bab71151df48fca39 /plugins/Makefile.am
parent03a35e0759f378729e42cc8fa42c5f6b471b3ac7 (diff)
downloadrpm-b5e3e1efee28ce0a4bb5e9eae6740d4422f75f1c.tar.gz
Eliminate built-in selinux support. RIP.
- We hereby unceremoniously declare that from now on, SELinux and other similar mechanisms are to live in plugins, rpm doesn't need to know about every possible security etc mechanism there might be. Its a big commit but as its really just removals... - We need to disable sepolicy collection plugin for now as it relies on built-in support for selinux, this not only makes no sense but wont work now that there is no built-in support. The sepolicy plugin needs to be merged into the selinux base plugin now. - Another "breakage" is that --rebuilddb no longer relabels the database, this needs plugins to called in a place where they currently cannot be called. This needs to be resolved before next actual release.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 0dce462a2..b36f68436 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -23,10 +23,11 @@ selinux_la_SOURCES = plugin.h selinux.c
selinux_la_LIBADD = $(top_builddir)/lib/librpm.la $(top_builddir)/rpmio/librpmio.la @WITH_SELINUX_LIB@
plugins_LTLIBRARIES += selinux.la
-sepolicy_la_SOURCES = plugin.h sepolicy.c
-sepolicy_la_LIBADD = $(top_builddir)/lib/librpm.la $(top_builddir)/rpmio/librpmio.la @WITH_SELINUX_LIB@ @WITH_SEMANAGE_LIB@
-
-plugins_LTLIBRARIES += sepolicy.la
+# XXX: merge this into selinux plugin, for now we need to disable
+# as it relies on in-core selinux knowledge which we no longer have...
+#sepolicy_la_SOURCES = plugin.h sepolicy.c
+#sepolicy_la_LIBADD = $(top_builddir)/lib/librpm.la $(top_builddir)/rpmio/librpmio.la @WITH_SELINUX_LIB@ @WITH_SEMANAGE_LIB@
+#plugins_LTLIBRARIES += sepolicy.la
endif
if DBUS