summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorSteve Lawrence <slawrence@tresys.com>2010-08-30 16:32:31 -0400
committerPanu Matilainen <pmatilai@redhat.com>2010-09-01 09:31:03 +0300
commit46cdd1b5073a6b7cdf0e23723f54958ec2f8c97e (patch)
tree539e6c5180aafcc38624536b96a732f25b03a08f /plugins/Makefile.am
parent34b5d67c2d3d68a48f0975dc6111a8c184d1c2dd (diff)
downloadrpm-46cdd1b5073a6b7cdf0e23723f54958ec2f8c97e.tar.gz
Add SELinux policy plugin
This adds a new plugin specifically for a collection to load SELinux policy. This implements the post_add and pre_remove plugin hooks. The only time anything happens during the pre_remove hook is if post_add was not called (i.e. if the transaction only removes policies). This plugin extracts all the policy information from packages in the sepolicy collection during the open te hook. It then determines which policies should be installed/removed based on if the package is being installed/removed and the type of the policy and the system policy. It then executes semodule (or uses libsemanage if semodule cannot be executed or installing in a chroot) to remove and install the necessary policies. It then reloads the selinux state, reloads the file contexts, and if necessary, relabels the file system.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 07560f07a..25774c42c 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -13,7 +13,11 @@ AM_LDFLAGS = -avoid-version -module -shared
pluginsdir = $(rpmconfigdir)/plugins
-plugins_LTLIBRARIES = exec.la
+plugins_LTLIBRARIES = exec.la sepolicy.la
exec_la_SOURCES = plugin.h exec.c
exec_la_LIBADD = $(top_builddir)/lib/librpm.la $(top_builddir)/rpmio/librpmio.la
+
+sepolicy_la_SOURCES = plugin.h sepolicy.c
+sepolicy_la_LIBADD = $(top_builddir)/lib/librpm.la $(top_builddir)/rpmio/librpmio.la @WITH_SELINUX_LIB@
+