summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Beckett <dave@dajobe.org>2005-01-03 19:32:32 +0000
committerDave Beckett <dave@dajobe.org>2005-01-03 19:32:32 +0000
commit8b3a5171c8630748c5e34c174e361dfab9018a98 (patch)
tree6eaa69089835901a803624a9faa6802db1bea228 /Makefile.am
parent00497225862631903a9a5da891101bdaca63b8f2 (diff)
downloadraptor-8b3a5171c8630748c5e34c174e361dfab9018a98.tar.gz
Link libraptor.la for URI tests, to get the namespace URI string
constants.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e2689437..1a9d6be2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -197,11 +197,11 @@ raptor_parse_test: $(srcdir)/raptor_general.c libraptor.la
raptor_rfc2396_test: $(srcdir)/raptor_rfc2396.c libraptor.la
$(LINK) $(DEFS) $(CPPFLAGS) -I$(srcdir) -I. -DSTANDALONE $(srcdir)/raptor_rfc2396.c libraptor.la $(LIBS)
-raptor_uri_test: $(srcdir)/raptor_uri.c raptor_rfc2396.lo
- $(LINK) $(DEFS) $(CPPFLAGS) -I$(srcdir) -I. -DSTANDALONE $(srcdir)/raptor_uri.c raptor_rfc2396.lo $(LIBS)
+raptor_uri_test: $(srcdir)/raptor_uri.c libraptor.la
+ $(LINK) $(DEFS) $(CPPFLAGS) -I$(srcdir) -I. -DSTANDALONE $(srcdir)/raptor_uri.c libraptor.la $(LIBS)
-raptor_uri_win32_test: $(srcdir)/raptor_uri.c raptor_rfc2396.lo
- $(LINK) $(DEFS) $(CPPFLAGS) -I$(srcdir) -I. -DSTANDALONE -DWIN32_URI_TEST $(srcdir)/raptor_uri.c raptor_rfc2396.lo $(LIBS)
+raptor_uri_win32_test: $(srcdir)/raptor_uri.c libraptor.la
+ $(LINK) $(DEFS) $(CPPFLAGS) -I$(srcdir) -I. -DSTANDALONE -DWIN32_URI_TEST $(srcdir)/raptor_uri.c libraptor.la $(LIBS)
raptor_namespace_test: $(srcdir)/raptor_namespace.c libraptor.la
$(LINK) $(DEFS) $(CPPFLAGS) -I$(srcdir) -I. -DSTANDALONE $(srcdir)/raptor_namespace.c libraptor.la $(LIBS)