summaryrefslogtreecommitdiff
path: root/src/host-ocaml/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2021-12-03 12:20:54 -0800
committerAdrian Thurston <thurston@colm.net>2021-12-03 12:20:54 -0800
commitac50c29844dce064c2310e0460c6b8ed1a60a786 (patch)
treecfc9829b23d2f146a3b8230f65cc3c02891cfeed /src/host-ocaml/Makefile.am
parente7b97a1f1fe3d59246c9e5488213f049b91fe047 (diff)
downloadragel-ac50c29844dce064c2310e0460c6b8ed1a60a786.tar.gz
include common ragel grammar and reduction code in rlparse deps
The language-specific parsing code should depend on the common grammar and reduction rules.
Diffstat (limited to 'src/host-ocaml/Makefile.am')
-rw-r--r--src/host-ocaml/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/host-ocaml/Makefile.am b/src/host-ocaml/Makefile.am
index fdadc500..67ff427d 100644
--- a/src/host-ocaml/Makefile.am
+++ b/src/host-ocaml/Makefile.am
@@ -13,7 +13,9 @@ BUILT_SOURCES = rlparse.c rlreduce.cc rlhc.c
EXTRA_DIST = rlparse.lm
-rlparse.pack: rlparse.lm $(COLM) $(COLM_WRAP)
+LM_DEPS = ../ragel.lm ../rlreduce.lm
+
+rlparse.pack: rlparse.lm $(COLM) $(COLM_WRAP) $(LM_DEPS)
$(COLM_WRAP) -c -I .. -b rlparseOCaml -o $@ -p rlparse.c -m rlreduce.cc $<
rlparse.c: rlparse.pack