summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..bad475b
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Generated from tests.pro.
+
+if(QT_BUILD_STANDALONE_TESTS)
+ # Add qt_find_package calls for extra dependencies that need to be found when building
+ # the standalone tests here.
+ # special case begin
+ if(NOT TARGET XCB::XCB)
+ qt_find_package(XCB REQUIRED PROVIDED_TARGETS XCB::XCB)
+ endif()
+ # special case end
+endif()
+qt_build_tests()