summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index ccb1f5e..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-# Generated from qtx11extras.pro.
-
-cmake_minimum_required(VERSION 3.15.0)
-
-include(.cmake.conf)
-project(QtX11Extras
- VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt X11 Extras" # special case
- HOMEPAGE_URL "https://qt.io/"
- LANGUAGES CXX C
-)
-
-# special case begin
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-# special case end
-
-# special case begin
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Widgets)
-
-if(NOT TARGET Qt::Gui)
- message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
- return()
-endif()
-# special case end
-
-qt_build_repo()
-