summaryrefslogtreecommitdiff
path: root/tests/auto/websockets/qwebsocket/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/websockets/qwebsocket/CMakeLists.txt')
-rw-r--r--tests/auto/websockets/qwebsocket/CMakeLists.txt20
1 files changed, 18 insertions, 2 deletions
diff --git a/tests/auto/websockets/qwebsocket/CMakeLists.txt b/tests/auto/websockets/qwebsocket/CMakeLists.txt
index ef9a63b..a70d61b 100644
--- a/tests/auto/websockets/qwebsocket/CMakeLists.txt
+++ b/tests/auto/websockets/qwebsocket/CMakeLists.txt
@@ -1,15 +1,31 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qwebsocket.pro.
#####################################################################
## tst_qwebsocket Test:
#####################################################################
-qt_add_test(tst_qwebsocket
+qt_internal_add_test(tst_qwebsocket
SOURCES
tst_qwebsocket.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::WebSockets
)
+set(qwebsocketshared_resource_files
+ "../shared/localhost.cert"
+ "../shared/localhost.key"
+)
+qt_internal_add_resource(tst_qwebsocket "qwebsocketshared"
+ PREFIX
+ "/"
+ BASE
+ "../shared"
+ FILES
+ ${qwebsocketshared_resource_files}
+)
+
#### Keys ignored in scope 1:.:.:qwebsocket.pro:<TRUE>:
# TEMPLATE = "app"