summaryrefslogtreecommitdiff
path: root/tests/auto/qml/qmlwebsockets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmlwebsockets/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmlwebsockets/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/auto/qml/qmlwebsockets/CMakeLists.txt b/tests/auto/qml/qmlwebsockets/CMakeLists.txt
index ca1557c..b85fc49 100644
--- a/tests/auto/qml/qmlwebsockets/CMakeLists.txt
+++ b/tests/auto/qml/qmlwebsockets/CMakeLists.txt
@@ -1,15 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qmlwebsockets.pro.
#####################################################################
## tst_qmlwebsockets Test:
#####################################################################
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ *.qml)
+list(APPEND test_data ${test_data_glob})
-qt_add_test(tst_qmlwebsockets
+qt_internal_add_test(tst_qmlwebsockets
QMLTEST
SOURCES
tst_qmlwebsockets.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
+ TESTDATA ${test_data}
)
#### Keys ignored in scope 1:.:.:qmlwebsockets.pro:<TRUE>: