summaryrefslogtreecommitdiff
path: root/src/imports/qmlwebsockets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/qmlwebsockets/CMakeLists.txt')
-rw-r--r--src/imports/qmlwebsockets/CMakeLists.txt27
1 files changed, 12 insertions, 15 deletions
diff --git a/src/imports/qmlwebsockets/CMakeLists.txt b/src/imports/qmlwebsockets/CMakeLists.txt
index c182e6c..b937fe1 100644
--- a/src/imports/qmlwebsockets/CMakeLists.txt
+++ b/src/imports/qmlwebsockets/CMakeLists.txt
@@ -1,25 +1,22 @@
-# Generated from qmlwebsockets.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## qmlwebsockets Plugin:
-#####################################################################
-
-qt_add_qml_module(qmlwebsockets
+qt_internal_add_qml_module(qmlwebsockets
URI "QtWebSockets"
- VERSION "1.0" #special case
- CLASSNAME QtWebSocketsDeclarativeModule
- SKIP_TYPE_REGISTRATION
+ VERSION "${PROJECT_VERSION}"
+ PAST_MAJOR_VERSIONS 1
+ CLASS_NAME QtWebSocketsDeclarativeModule
+ PLUGIN_TARGET qmlwebsockets
+ NO_PLUGIN_OPTIONAL
+ NO_GENERATE_PLUGIN_SOURCE
+ NO_GENERATE_QMLTYPES
+ INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
qmlwebsockets_plugin.cpp qmlwebsockets_plugin.h
qqmlwebsocket.cpp qqmlwebsocket.h
qqmlwebsocketserver.cpp qqmlwebsocketserver.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
Qt::WebSockets
)
-
-#### Keys ignored in scope 1:.:.:qmlwebsockets.pro:<TRUE>:
-# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
-# OTHER_FILES = "qmldir"
-# TARGETPATH = "QtWebSockets"