summaryrefslogtreecommitdiff
path: root/examples/websockets/sslechoclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/sslechoclient/CMakeLists.txt')
-rw-r--r--examples/websockets/sslechoclient/CMakeLists.txt12
1 files changed, 4 insertions, 8 deletions
diff --git a/examples/websockets/sslechoclient/CMakeLists.txt b/examples/websockets/sslechoclient/CMakeLists.txt
index 26a1d05..3723e38 100644
--- a/examples/websockets/sslechoclient/CMakeLists.txt
+++ b/examples/websockets/sslechoclient/CMakeLists.txt
@@ -1,30 +1,26 @@
-# Generated from sslechoclient.pro.
-
cmake_minimum_required(VERSION 3.16)
project(sslechoclient LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/websockets/sslechoclient")
-find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 REQUIRED COMPONENTS WebSockets)
qt_add_executable(sslechoclient
main.cpp
sslechoclient.cpp sslechoclient.h
)
+
set_target_properties(sslechoclient PROPERTIES
WIN32_EXECUTABLE FALSE
MACOSX_BUNDLE FALSE
)
+
target_link_libraries(sslechoclient PUBLIC
Qt::WebSockets
)