summaryrefslogtreecommitdiff
path: root/examples/websockets/sslechoclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/sslechoclient/CMakeLists.txt')
-rw-r--r--examples/websockets/sslechoclient/CMakeLists.txt26
1 files changed, 17 insertions, 9 deletions
diff --git a/examples/websockets/sslechoclient/CMakeLists.txt b/examples/websockets/sslechoclient/CMakeLists.txt
index b1269f2..b629a9d 100644
--- a/examples/websockets/sslechoclient/CMakeLists.txt
+++ b/examples/websockets/sslechoclient/CMakeLists.txt
@@ -1,26 +1,34 @@
-# Generated from sslechoclient.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(sslechoclient LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/websockets/sslechoclient")
-find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 REQUIRED COMPONENTS WebSockets)
-add_executable(sslechoclient
+qt_add_executable(sslechoclient
main.cpp
sslechoclient.cpp sslechoclient.h
)
+
+qt_add_resources(sslechoclient "cert"
+ BASE ../sslechoserver
+ FILES ../sslechoserver/localhost.cert
+)
+
+set_target_properties(sslechoclient PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ MACOSX_BUNDLE FALSE
+)
+
target_link_libraries(sslechoclient PUBLIC
Qt::WebSockets
)