summaryrefslogtreecommitdiff
path: root/examples/websockets/qmlwebsocketserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/qmlwebsocketserver/CMakeLists.txt')
-rw-r--r--examples/websockets/qmlwebsocketserver/CMakeLists.txt16
1 files changed, 4 insertions, 12 deletions
diff --git a/examples/websockets/qmlwebsocketserver/CMakeLists.txt b/examples/websockets/qmlwebsocketserver/CMakeLists.txt
index a9b14fc..1f93cb4 100644
--- a/examples/websockets/qmlwebsocketserver/CMakeLists.txt
+++ b/examples/websockets/qmlwebsocketserver/CMakeLists.txt
@@ -1,32 +1,25 @@
-# Generated from qmlwebsocketserver.pro.
-
cmake_minimum_required(VERSION 3.16)
project(qmlwebsocketserver LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/websockets/qmlwebsocketserver")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Quick WebSockets)
qt_add_executable(qmlwebsocketserver
main.cpp
)
+
set_target_properties(qmlwebsocketserver PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE FALSE
)
+
target_link_libraries(qmlwebsocketserver PUBLIC
Qt::Core
Qt::Gui
@@ -34,7 +27,6 @@ target_link_libraries(qmlwebsocketserver PUBLIC
Qt::WebSockets
)
-
# Resources:
set(data_resource_files
"qml/qmlwebsocketserver/main.qml"