summaryrefslogtreecommitdiff
path: root/examples/websockets/echoclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/echoclient/CMakeLists.txt')
-rw-r--r--examples/websockets/echoclient/CMakeLists.txt13
1 files changed, 4 insertions, 9 deletions
diff --git a/examples/websockets/echoclient/CMakeLists.txt b/examples/websockets/echoclient/CMakeLists.txt
index 4166071..e366612 100644
--- a/examples/websockets/echoclient/CMakeLists.txt
+++ b/examples/websockets/echoclient/CMakeLists.txt
@@ -1,31 +1,26 @@
-# Generated from echoclient.pro.
-
cmake_minimum_required(VERSION 3.16)
project(echoclient LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/websockets/echoclient")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 REQUIRED COMPONENTS Core WebSockets)
qt_add_executable(echoclient
echoclient.cpp echoclient.h
main.cpp
)
+
set_target_properties(echoclient PROPERTIES
WIN32_EXECUTABLE FALSE
MACOSX_BUNDLE FALSE
)
+
target_link_libraries(echoclient PUBLIC
Qt::Core
Qt::WebSockets