summaryrefslogtreecommitdiff
path: root/examples/websockets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/websockets/CMakeLists.txt')
-rw-r--r--examples/websockets/CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/examples/websockets/CMakeLists.txt b/examples/websockets/CMakeLists.txt
index 196d6a1..25901f5 100644
--- a/examples/websockets/CMakeLists.txt
+++ b/examples/websockets/CMakeLists.txt
@@ -1,13 +1,14 @@
-# Generated from websockets.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-add_subdirectory(echoclient)
-add_subdirectory(echoserver)
-add_subdirectory(simplechat)
+qt_internal_add_example(echoclient)
+qt_internal_add_example(echoserver)
+qt_internal_add_example(simplechat)
if(TARGET Qt::Quick)
- add_subdirectory(qmlwebsocketclient)
- add_subdirectory(qmlwebsocketserver)
+ qt_internal_add_example(qmlwebsocketclient)
+ qt_internal_add_example(qmlwebsocketserver)
endif()
if(QT_FEATURE_ssl)
- add_subdirectory(sslechoserver)
- add_subdirectory(sslechoclient)
+ qt_internal_add_example(sslechoserver)
+ qt_internal_add_example(sslechoclient)
endif()