summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-23 16:03:25 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-23 15:08:34 +0000
commita674d83d75a1f80fee8de63f8a5e2aadab931124 (patch)
tree049f42db9ef1da77156839b605b5b4e3a0d672f1 /tests/CMakeLists.txt
parent6b19edaefe7edcdc12a1faa269d77e42a14fc81d (diff)
downloadqtwebsockets-wip/cmake.tar.gz
CMake: Regenerate projects after mergewip/cmake
Change-Id: I3cdf755e3aae933016b9719ce4c61f53e554ea48 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3d7cc10..8825444 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,10 +1,8 @@
# Generated from tests.pro.
-if(NOT TARGET Qt::Test)
- cmake_minimum_required(VERSION 3.15.0)
- project(QtWebSocketsTests VERSION 6.0.0 LANGUAGES C CXX)
- find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS BuildInternals Core Network Test Qml Quick QuickTest WebSockets) # special case
- qt_set_up_standalone_tests_build()
+if(QT_BUILD_STANDALONE_TESTS)
+ # Add qt_find_package calls for extra dependencies that need to be found when building
+ # the standalone tests here.
endif()
qt_build_tests()