summaryrefslogtreecommitdiff
path: root/src/imports
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2019-09-16 14:22:07 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-09-16 14:47:09 +0000
commita3c87a0e44bb67cc3f726dd915178f9f307480e8 (patch)
tree6b40f1f687dd6e25d71e41c37eed2b230524e83f /src/imports
parenta5b0495ac273bcc841298b52dae3ca9bb608edf7 (diff)
downloadqtwebsockets-a3c87a0e44bb67cc3f726dd915178f9f307480e8.tar.gz
Add initial-support for cmake
Task-number: QTBUG-78180 Change-Id: If6cf82c61d605332402feffca9bde2ea0dd6e313 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/CMakeLists.txt4
-rw-r--r--src/imports/qmlwebsockets/CMakeLists.txt29
2 files changed, 33 insertions, 0 deletions
diff --git a/src/imports/CMakeLists.txt b/src/imports/CMakeLists.txt
new file mode 100644
index 0000000..e202821
--- /dev/null
+++ b/src/imports/CMakeLists.txt
@@ -0,0 +1,4 @@
+# Generated from imports.pro.
+
+add_subdirectory(qmlwebsockets)
+#add_subdirectory(qmlwebsockets_compat) # special case
diff --git a/src/imports/qmlwebsockets/CMakeLists.txt b/src/imports/qmlwebsockets/CMakeLists.txt
new file mode 100644
index 0000000..04f7f6b
--- /dev/null
+++ b/src/imports/qmlwebsockets/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from qmlwebsockets.pro.
+
+#####################################################################
+## qmlwebsockets Plugin:
+#####################################################################
+
+add_qml_module(qmlwebsockets
+ CPP_PLUGIN
+ URI "QtWebSockets"
+ VERSION "1.0" #special case
+ #VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ SOURCES
+ qmlwebsockets_plugin.cpp qmlwebsockets_plugin.h
+ qqmlwebsocket.cpp qqmlwebsocket.h
+ qqmlwebsocketserver.cpp qqmlwebsocketserver.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::WebSockets
+)
+
+#### Keys ignored in scope 1:.:.:qmlwebsockets.pro:<TRUE>:
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir"
+# TARGETPATH = "QtWebSockets"
+# _LOADED = "qml_plugin"