summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2019-09-16 14:22:07 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-09-16 14:47:09 +0000
commita3c87a0e44bb67cc3f726dd915178f9f307480e8 (patch)
tree6b40f1f687dd6e25d71e41c37eed2b230524e83f /CMakeLists.txt
parenta5b0495ac273bcc841298b52dae3ca9bb608edf7 (diff)
downloadqtwebsockets-a3c87a0e44bb67cc3f726dd915178f9f307480e8.tar.gz
Add initial-support for cmake
Task-number: QTBUG-78180 Change-Id: If6cf82c61d605332402feffca9bde2ea0dd6e313 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d1cfcae
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.15.0)
+
+project(QtWebSockets
+ VERSION 6.0.0
+ DESCRIPTION "Qt WebSockets Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Quick QuickTest)
+qt_build_repo()