summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-06-24 16:42:40 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-24 20:51:43 +0200
commit6c00e510619f2bf9f997c1df5b00f03780d57dd3 (patch)
tree7f9dac7b5b10cdfe1fef505dd8527402ed459825 /CMakeLists.txt
parentf7f36efe0e933b86b88b7f2156bc0d646a3b45ee (diff)
downloadqtwebsockets-6c00e510619f2bf9f997c1df5b00f03780d57dd3.tar.gz
CMake: Regenerate projects
Mostly needed for src/ project, to build websockets without checking for the textcodec feature. Amends aeeaa00fa083ac339d0770d633d22f203c504253 Change-Id: I90cd219294575c763501e47b9025e8a50017641a Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59289c3..8e83d3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,9 @@
cmake_minimum_required(VERSION 3.15.0)
+include(.cmake.conf)
project(QtWebSockets # special case
- VERSION 6.0.0
+ VERSION "${QT_REPO_MODULE_VERSION}"
DESCRIPTION "Qt WebSockets Libraries" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C