summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-15 16:32:06 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-15 14:40:28 +0000
commit432b75517cba65e8ab633a2fe0d53f18abd59426 (patch)
tree2ba828e91dc228237e63a346c0ab7bc09fde83c5 /CMakeLists.txt
parent5feeb5867d032cc4641ee088cfa5bd9063bcf5cd (diff)
downloadqtwebsockets-432b75517cba65e8ab633a2fe0d53f18abd59426.tar.gz
Regenerate before merge
Change-Id: I9f22f5d050aeec3e8c308e286a897f0f524ed8e3 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1cfcae..59289c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,20 @@
+# Generated from qtwebsockets.pro.
+
cmake_minimum_required(VERSION 3.15.0)
-project(QtWebSockets
+project(QtWebSockets # special case
VERSION 6.0.0
- DESCRIPTION "Qt WebSockets Libraries"
+ DESCRIPTION "Qt WebSockets Libraries" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Quick QuickTest)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Quick QuickTest) # special case
+
+if(NOT TARGET Qt::Network)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
+ return()
+endif()
qt_build_repo()
+