summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Tokarev <annulen@yandex.ru>2019-10-03 22:48:16 +0300
committerKonstantin Tokarev <annulen@yandex.ru>2019-10-04 02:11:52 +0300
commit3395426ab651a631aca8ee6b0a694a71df19100f (patch)
tree4d1d20f3630ef5e68ee17fa8b3f3de9f3269ec19 /CMakeLists.txt
parentb47f584d07aec2d78ea4a5a5ccf2c761f44f5585 (diff)
downloadqtwebkit-3395426ab651a631aca8ee6b0a694a71df19100f.tar.gz
Import QtWebKit commit 49b749171e786df3adcd7a755df428c1846acd69
Change-Id: I4c82d8030969d941bb78b1cc4e77c0a66db8da2c Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb92a7a5c..31a2ea1fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,6 +141,11 @@ include(WebKitCommon)
# -----------------------------------------------------------------------------
if (ENABLE_API_TESTS)
enable_testing()
+
+ # Qt API tests are at top level because of Coin requirements
+ if (${PORT} STREQUAL "Qt")
+ add_subdirectory(tests)
+ endif ()
endif ()
# -----------------------------------------------------------------------------