summaryrefslogtreecommitdiff
path: root/tests/auto/webchannel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/webchannel/CMakeLists.txt')
-rw-r--r--tests/auto/webchannel/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/webchannel/CMakeLists.txt b/tests/auto/webchannel/CMakeLists.txt
new file mode 100644
index 0000000..1f7d734
--- /dev/null
+++ b/tests/auto/webchannel/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from webchannel.pro.
+
+#####################################################################
+## tst_webchannel Test:
+#####################################################################
+
+qt_add_test(tst_webchannel
+ SOURCES
+ tst_webchannel.cpp tst_webchannel.h
+ INCLUDE_DIRECTORIES
+ ../../../src/webchannel
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::WebChannelPrivate
+ PUBLIC_LIBRARIES
+ Qt::WebChannel
+)
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_webchannel CONDITION TARGET Qt::Qml
+ DEFINES
+ WEBCHANNEL_TESTS_CAN_USE_JS_ENGINE
+ PUBLIC_LIBRARIES
+ Qt::Qml
+)