summaryrefslogtreecommitdiff
path: root/src/webchannelquick/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/webchannelquick/CMakeLists.txt')
-rw-r--r--src/webchannelquick/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/webchannelquick/CMakeLists.txt b/src/webchannelquick/CMakeLists.txt
new file mode 100644
index 0000000..0c88145
--- /dev/null
+++ b/src/webchannelquick/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(WebChannelQuick
+ URI "QtWebChannel"
+ VERSION "${PROJECT_VERSION}"
+ PAST_MAJOR_VERSIONS 1
+ GENERATE_CPP_EXPORTS
+ SOURCES
+ qqmlwebchannel.h qqmlwebchannel.cpp
+ qqmlwebchannelattached_p.h qqmlwebchannelattached.cpp
+ qwebchannelquickglobal.h
+ LIBRARIES
+ Qt::WebChannelPrivate
+)