summaryrefslogtreecommitdiff
path: root/examples/webchannel/chatserver-cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webchannel/chatserver-cpp/CMakeLists.txt')
-rw-r--r--examples/webchannel/chatserver-cpp/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/examples/webchannel/chatserver-cpp/CMakeLists.txt b/examples/webchannel/chatserver-cpp/CMakeLists.txt
new file mode 100644
index 0000000..3a3a2c9
--- /dev/null
+++ b/examples/webchannel/chatserver-cpp/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from chatserver-cpp.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(chatserver LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/webchannel/chatserver-cpp")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS WebSockets)
+find_package(Qt6 COMPONENTS WebChannel)
+
+add_executable(chatserver
+ ../shared/websocketclientwrapper.cpp ../shared/websocketclientwrapper.h
+ ../shared/websockettransport.cpp ../shared/websockettransport.h
+ chatserver.cpp chatserver.h
+ main.cpp
+)
+target_link_libraries(chatserver PUBLIC
+ Qt::Core
+ Qt::WebChannel
+ Qt::WebSockets
+)
+
+install(TARGETS chatserver
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)