summaryrefslogtreecommitdiff
path: root/examples/webchannel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webchannel/CMakeLists.txt')
-rw-r--r--examples/webchannel/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/examples/webchannel/CMakeLists.txt b/examples/webchannel/CMakeLists.txt
new file mode 100644
index 0000000..78c2fb6
--- /dev/null
+++ b/examples/webchannel/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Generated from webchannel.pro.
+
+# special case begin
+# These are all TEMPLATE = aux
+#add_subdirectory(nodejs)
+#add_subdirectory(qwclient)
+#add_subdirectory(chatclient-html)
+# special case end
+if(TARGET Qt::WebSockets)
+ add_subdirectory(chatserver-cpp)
+ # special case begin
+ # This one is TEMPLATE = aux too
+ #add_subdirectory(chatclient-qml)
+ # special case end
+endif()
+if(TARGET Qt::WebSockets AND TARGET Qt::Widgets)
+ add_subdirectory(standalone)
+endif()