summaryrefslogtreecommitdiff
path: root/src/client/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2022-04-22 13:54:11 -0700
committerThiago Macieira <thiago.macieira@intel.com>2022-04-28 20:57:04 -0700
commite1854451c46513fcfad0f92abc836b9cb6fa454a (patch)
tree8103972a9a9930e697cc5cba36cbee95cfa6d6cc /src/client/CMakeLists.txt
parentaee5dbf01c24a1487847d996647b0c53f1f20e8b (diff)
downloadqtwayland-e1854451c46513fcfad0f92abc836b9cb6fa454a.tar.gz
QtWaylandClient: use the CMake exports.h support
The one in qtwaylandglobal.h was wrong. It just happened to work on Linux because the lack of import wasn't an error... until GCC 12 with -mno-direct-extern-access. Pick-to: 6.3 Change-Id: If05aeeb7176e4f13af9afffd16e8535b469f9158 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
Diffstat (limited to 'src/client/CMakeLists.txt')
-rw-r--r--src/client/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/client/CMakeLists.txt b/src/client/CMakeLists.txt
index 1041f31e..be6065c1 100644
--- a/src/client/CMakeLists.txt
+++ b/src/client/CMakeLists.txt
@@ -6,6 +6,7 @@
qt_internal_add_module(WaylandClient
PLUGIN_TYPES wayland-graphics-integration-client wayland-inputdevice-integration wayland-decoration-client wayland-shell-integration
+ GENERATE_CPP_EXPORTS
SOURCES
../shared/qwaylandinputmethodeventbuilder.cpp ../shared/qwaylandinputmethodeventbuilder_p.h
../shared/qwaylandmimehelper.cpp ../shared/qwaylandmimehelper_p.h