summaryrefslogtreecommitdiff
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 31b62c6..c5c9961 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,10 +1,19 @@
-# Generated from auto.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# For now, don't built auto tests when QT_BUILD_MINIMAL_STATIC_TEST
+# is specified and the build is targeting iOS. QT_BUILD_MINIMAL_STATIC_TEST is used in our CI.
+# Regular non-cmake build tests shouldn't be built because the CI will try to run them and fail
+# due to missing simulator support.
+if(IOS AND QT_BUILD_MINIMAL_STATIC_TESTS)
+ return()
+endif()
if(TARGET Qt::Widgets)
add_subdirectory(qsvgdevice)
- if(TARGET Qt::Xml) # special case
- add_subdirectory(qsvggenerator) # special case
- endif() # special case
+ if(TARGET Qt::Xml)
+ add_subdirectory(qsvggenerator)
+ endif()
add_subdirectory(qsvgplugin)
add_subdirectory(qicon_svg)
# add_subdirectory(cmake) # special case remove