summaryrefslogtreecommitdiff
path: root/tests/auto/qicon_svg/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kfunk@kde.org>2019-02-13 12:59:44 +0100
committerKevin Funk <kevin.funk@kdab.com>2019-05-03 13:50:55 +0000
commit775922d2315dddcd2750acf5d3a8a90d368dc000 (patch)
tree8013bea5d1939cc6de8830f7209dc0c3c964d7ef /tests/auto/qicon_svg/CMakeLists.txt
parentd0cba8947e5261dff56cb379d7462855d1eb7263 (diff)
downloadqtsvg-775922d2315dddcd2750acf5d3a8a90d368dc000.tar.gz
cmake: Initial CMake build system support
Task-number: QTBUG-74135 Done-With: Alexandru Croitor <alexandru.croitor@qt.io> Done-With: Liang Qi <liang.qi@qt.io> Change-Id: I81fdc3d06f53e78182352214ef4687924dfc6fb6 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/qicon_svg/CMakeLists.txt')
-rw-r--r--tests/auto/qicon_svg/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/auto/qicon_svg/CMakeLists.txt b/tests/auto/qicon_svg/CMakeLists.txt
new file mode 100644
index 0000000..d314181
--- /dev/null
+++ b/tests/auto/qicon_svg/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from qicon_svg.pro.
+
+#####################################################################
+## tst_qicon_svg Test:
+#####################################################################
+
+add_qt_test(tst_qicon_svg
+ SOURCES
+ tst_qicon_svg.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Svg
+)
+
+# Resources:
+add_qt_resource(tst_qicon_svg "tst_qicon_svg" PREFIX "/" FILES
+ ./icons/heart.svg
+ ./icons/heart.svgz
+ ./icons/image.png
+ ./icons/rect.svg
+ ./icons/rect_size_100percent.svg
+ ./icons/trash.svg)
+
+
+#### Keys ignored in scope 1:.:.:qicon_svg.pro:<TRUE>:
+# CONFIG = "testcase"
+# TESTDATA = "icons/*"