summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-15 11:36:06 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-15 11:40:26 +0000
commit555df188da00a5d4b33bd2ac0c1de66a7704b750 (patch)
tree6633d12ca78a71a9a0237d9a646f96eed97bd68c /CMakeLists.txt
parent775922d2315dddcd2750acf5d3a8a90d368dc000 (diff)
downloadqtsvg-555df188da00a5d4b33bd2ac0c1de66a7704b750.tar.gz
Use the new macros introduced in qtbase for building qtsvg
This cleans up the top-level CMakeLists.txt file. Task-number: QTBUG-75580 Change-Id: I094d9d63937664b98b5ccfb624ffc4aa91859fe7 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1a329a..94ec488 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,19 +8,7 @@ project(QtSvg
)
find_package(Qt5 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Core Gui Widgets)
-
-# TODO: Maybe make this var part of the find script already?
-set(QT_CMAKE_MODULE_PATH "${_qt_cmake_dir}/Qt5")
-list(APPEND CMAKE_MODULE_PATH ${QT_CMAKE_MODULE_PATH})
-list(APPEND CMAKE_PREFIX_PATH ${QT_CMAKE_MODULE_PATH})
-
-## Should this Qt be static or dynamically linked?
-option(BUILD_SHARED_LIBS "Build Qt statically or dynamically" ON)
-set(QT_BUILD_SHARED_LIBS ${BUILD_SHARED_LIBS})
-
-include(QtSetup)
-
-include(FeatureSummary)
+qt_build_repo_begin()
add_subdirectory(src)
@@ -34,8 +22,4 @@ if (BUILD_EXAMPLES)
#add_subdirectory(examples)
endif()
-## Delayed actions on some of the Qt targets:
-include(QtPostProcess)
-
-## Print a feature summary:
-feature_summary(WHAT PACKAGES_FOUND PACKAGES_NOT_FOUND FATAL_ON_MISSING_REQUIRED_PACKAGES)
+qt_build_repo_end()