summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-05-21 09:07:17 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-05-21 08:05:54 +0000
commit02b9da194f60b87ae291aa13401be6759533ddcf (patch)
tree9f0d60ee4790d78243d9ec66fbb47f28fd6c6f65 /CMakeLists.txt
parent5b641f4722b295265ebfcaee2d95bb104218a068 (diff)
downloadqtsvg-02b9da194f60b87ae291aa13401be6759533ddcf.tar.gz
Use qt_build_repo() to simplify top-level CMakeLists.txt
Change-Id: Ic120895d1789db29f4218fcf6e01bacb8af3e13a Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c76309b..50b2b08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,18 +8,4 @@ project(QtSvg
)
find_package(Qt5 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets)
-qt_build_repo_begin()
-
-add_subdirectory(src)
-
-if (BUILD_TESTING)
- find_package(Qt5 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Test Xml)
- add_subdirectory(tests)
-endif()
-
-if (BUILD_EXAMPLES)
- # TODO: Implement me
- #add_subdirectory(examples)
-endif()
-
-qt_build_repo_end()
+qt_build_repo()