summaryrefslogtreecommitdiff
path: root/examples/serialport/blockingreceiver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/serialport/blockingreceiver/CMakeLists.txt')
-rw-r--r--examples/serialport/blockingreceiver/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/examples/serialport/blockingreceiver/CMakeLists.txt b/examples/serialport/blockingreceiver/CMakeLists.txt
new file mode 100644
index 0000000..b2db3fe
--- /dev/null
+++ b/examples/serialport/blockingreceiver/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(blockingreceiver LANGUAGES CXX)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/serialport/blockingreceiver")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui SerialPort Widgets)
+
+qt_standard_project_setup()
+
+qt_add_executable(blockingreceiver
+ dialog.cpp dialog.h
+ main.cpp
+ receiverthread.cpp receiverthread.h
+)
+
+set_target_properties(blockingreceiver PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(blockingreceiver PRIVATE
+ Qt::Core
+ Qt::Gui
+ Qt::SerialPort
+ Qt::Widgets
+)
+
+install(TARGETS blockingreceiver
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)