summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2021-06-03 13:12:52 +0300
committerJuha Vuolle <juha.vuolle@insta.fi>2021-06-15 11:36:02 +0300
commit54b3ca67ad7230a21d76c581dd4287401acb230f (patch)
tree2d9b59930700cf99b7553c21a5846c4bee6f9191 /CMakeLists.txt
parentae82c50ca7fd5e356a736467e660acd976ec2e25 (diff)
downloadqtsensors-54b3ca67ad7230a21d76c581dd4287401acb230f.tar.gz
Increase QtSensors QML autotest coverage
This commit introduces QML based auto tests in order to increase the autotest coverage. Additionally the QML sensor activity handling is fixed which caused the newly added tests to fail. There are also long-standing bugs about these activeChanged() double emits. Pick-to: 6.2 Task-number: QTBUG-92514 Task-number: QTBUG-70770 Task-number: QTBUG-80755 Change-Id: I98f036f665a056c441efa00aab76ec47bc628057 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 230ad6a..0f6b8f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ project(QtSensors
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
- Xml Gui Widgets Quick Qml Svg DBus Multimedia Bluetooth
+ Xml Gui Widgets Quick Qml Svg DBus Multimedia Bluetooth QuickTest
)
qt_build_repo()